Platform Performance Issue
Incident Report for Teaching Strategies, LLC.
Resolved
This issue is fully resolved. You may need to clear your browser's cookies and cache if you are still experiencing issues.
Posted May 22, 2023 - 12:10 EDT
Monitoring
MyTeachingStrategies is now operating as expected. We will continue to monitor the system to ensure the issue is fully resolved. You may need to clear your browser's cookies and cache if you are still experiencing issues.
Posted May 22, 2023 - 10:34 EDT
Identified
This issue is due to our WAF (Web Application Firewall). Our team is actively addressing this issue, and we will provide further updates until this is fully resolved.
Posted May 22, 2023 - 10:28 EDT
Investigating
Users are unable to access MyTeachingStrategies. We are currently investigating the root cause of the issue and will provide more information as soon as possible.
Posted May 22, 2023 - 10:06 EDT
This incident affected: MyTeachingStrategies (Library Area, Teach Area, Assess Area, Develop Area, Quorum, The Hub, Report Area, Family Area, Administration Area).