When a Teaching Guide is removed from a plan, a bug is causing the template to also be removed. Teachers adding a new Teaching Guide may lose their saved template.
Workaround: Add as few Teaching Guides as possible until the fix is implemented.
Get email notifications whenever Teaching Strategies, LLC. creates, updates or resolves an incident.
Get incident updates and maintenance status messages in Slack.
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 04, 2025 - 08:09 EST
Scheduled
Due to system maintenance, Quorum will be unavailable on March 4 from 8:00AM EDT to 9:00AM EDT. We appreciate your patience and understanding as we make important updates.
Posted Mar 04, 2025 - 08:08 EST
This scheduled maintenance affected: SmartTeach (Quorum).