Platform Issue - SmartTeach

Incident Report for Teaching Strategies, LLC.

Resolved

All issues should now be resolved.
Posted Aug 25, 2025 - 15:44 EDT

Identified

Some users are experiencing issues logging in, we have identified the issue and are working on resolution. We expect these to be issues to be resolved shortly.
Posted Aug 25, 2025 - 13:09 EDT
This incident affected: SmartTeach (Library Area, Teach Area, Assess Area, Develop Area, Quorum, The Hub, Report Area, Family Area, Administration Area).