Platform Performance Issue - Tadpoles and Mobile Apps

Incident Report for Teaching Strategies, LLC.

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 17:27 EDT

Monitoring

Our upstream vendor is reporting a fix is implemented and recovery is in progress. No ETA on full resolution but we are seeing positive indicators and will continue to monitor.
Posted Jun 12, 2025 - 16:21 EDT

Investigating

Users may be currently experiencing degraded performance from Tadpoles and our mobile applications due to an issue with an upstream vendor. We will provide updates as we receive them.
Posted Jun 12, 2025 - 14:41 EDT
This incident affected: Tadpoles.