The degraded performance issue in Assess has been resolved and the “At a Glance”, “Checkpoints”, and documentation creation are restored. All documentation is now visible again - no action needed.
Posted 17 days ago. Apr 22, 2025 - 10:35 EDT
Identified
We have identified the issue causing the degraded performance and our team is working on a solution to resolve as soon as possible. We will continue to post updates as soon as a fix is applied.
Posted 18 days ago. Apr 21, 2025 - 11:03 EDT
Investigating
Some users are currently experiencing degraded performance and receiving errors from the Assess area of the Smart Teach platform. We are investigating the root cause of the issue and will provide more information as soon as possible.