Platform Performance Issue - Assess

Incident Report for Teaching Strategies, LLC.

Resolved

This incident has been resolved.
Posted Mar 28, 2025 - 13:50 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 28, 2025 - 13:11 EDT

Investigating

Users are currently receiving errors from the Assess area of the Smart Teach platform. We are investigating the root cause of the issue and will provide more information as soon as possible.
Posted Mar 28, 2025 - 12:43 EDT
This incident affected: SmartTeach (Assess Area).