Clever has resolved their issue and we are seeing no further issues with Clever SSO logins.
Posted Sep 17, 2025 - 19:50 EDT
Identified
We have identified the issue and it is affecting only users that rely on Clever SSO for login. Clever has acknowledged the issue but has provided no timeline for resolution. We will share updates as we receive them from Clever.
Posted Sep 17, 2025 - 16:20 EDT
Investigating
A subset of users who leverage SSO login are currently experiencing issues logging in. We are investigating the root cause of the issue and will provide more information as soon as possible.
Posted Sep 17, 2025 - 10:42 EDT
This incident affected: SmartTeach (Library Area, Teach Area, Assess Area, Develop Area, Quorum, The Hub, Report Area, Family Area, Administration Area).