Our upstream provider has resolved their issue and all services are restored.
Posted Jan 29, 2025 - 17:38 EST
Update
Our upstream vendor has indicated that they may have identified the root cause, though confirmation is still pending.
Posted Jan 29, 2025 - 16:31 EST
Update
We have identified the issue as an upstream provider. We will provide more updates as we get them from the provider.
Posted Jan 29, 2025 - 15:25 EST
Update
We are continuing to investigate this issue.
Posted Jan 29, 2025 - 15:10 EST
Investigating
Users are experiencing degraded performance on the Assess and teach modules of Smart Teach. We are currently investigating the root cause of the issue and will provide more information as soon as possible.
Posted Jan 29, 2025 - 15:08 EST
This incident affected: SmartTeach (Teach Area, Assess Area, Administration Area).