Upstream vendor has implemented a fix and we our Assess and Teach are now back online. We will continue to monitor.
Posted Jan 29, 2025 - 19:10 EST
Investigating
Users are experiencing degraded performance on the Assess and Teach modules of Smart Teach due to a recurrence of the upstream vendor issue. They are aware and working on a resolution.
Posted Jan 29, 2025 - 18:17 EST
This incident affected: SmartTeach (Teach Area, Assess Area, Administration Area).