A fix has been implemented and we are monitoring the results.
Posted Sep 08, 2026 - 10:58 EDT
Investigating
Some users are experiencing degraded performance with Tadpoles and the mobile apps. We are currently investigating the root cause of the issue and will provide more information as soon as possible.
Posted Sep 08, 2026 - 10:14 EDT
This incident affected: Mobile Applications (SmartTeach Mobile, Finch Mobile).