📌 Known Issues 0

Platform Status - SmartTeach

Incident Report for Teaching Strategies, LLC.

Resolved

This incident has been resolved.
Posted Jan 20, 2026 - 09:52 EST

Investigating

We are currently investigating an issue affecting the Teach area of SmartTeach. We are actively working to identify the root cause and will provide an update as soon as more information is available.
Posted Jan 20, 2026 - 09:32 EST
This incident affected: SmartTeach (Teach Area).