This issue is fully resolved. You may need to clear your browser's cookies and cache if you are still experiencing issues.
Posted Jun 27, 2025 - 17:32 EDT
Identified
We have identified the issue and implemented a fix. Data delays will be resolved shortly, we will continue to monitor and provide a final update when we are fully caught up.
Posted Jun 27, 2025 - 16:03 EDT
Investigating
Users are experiencing delays with updates to classes, children and passwords. We are currently investigating the root cause of the issue and will provide more information as soon as possible.
Posted Jun 27, 2025 - 13:51 EDT
This incident affected: SmartTeach (Library Area, Teach Area, Assess Area, Develop Area, Report Area, Family Area, Administration Area).