📌 Known Issues 0

Platform Status - SmartTeach and Finch Mobile

Incident Report for Teaching Strategies, LLC.

Resolved

This incident has been resolved.
Posted Nov 14, 2025 - 15:02 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 14, 2025 - 14:48 EST

Investigating

A subset of SSO users on the SmartTeach and Finch mobile apps are experiencing login issues. We are investigating and will provide updates as they become available. The web versions of these applications remain available and are not impacted.
Posted Nov 14, 2025 - 14:18 EST
This incident affected: Mobile Applications (SmartTeach Mobile, Finch Mobile).