A fix has been implemented and we are monitoring the results.
Posted Sep 01, 2026 - 14:54 EDT
Investigating
Some customers are experiencing issues with SmartTeach. This is due to an issue with a down stream provider. We will provide more information as soon as possible.
Posted Sep 01, 2026 - 14:08 EDT
This incident affected: SmartTeach (Library Area, Teach Area, Assess Area, Develop Area, Quorum, The Hub, Report Area, Family Area, Administration Area) and Tadpoles, ReadyRosie, Technical Support, Support Portal.