SmartTeach is now operating as expected. We will continue to monitor the system to ensure the issue is fully resolved. You may need to clear your browser's cookies and cache if you are still experiencing issues.
Posted Nov 21, 2024 - 14:59 EST
Identified
Some users are experiencing degraded performance in SmartTeach due to issues with our services provider. We are working with them to resolve the issue. We apologize for any inconvenience.
Posted Nov 21, 2024 - 14:14 EST
This incident affected: SmartTeach (Library Area, Teach Area, Assess Area, Develop Area, Quorum, The Hub, Report Area, Family Area, Administration Area).