Platform Performance Issue - SmartTeach

Incident Report for Teaching Strategies, LLC.

Resolved

This incident has been resolved.
Posted Aug 21, 2025 - 17:15 EDT

Monitoring

Our upstream provider reports that the issue is resolved. We have confirmed that SmartTeach availability and performance is now fully restored. We are continuing to monitor closely.
Posted Aug 21, 2025 - 15:47 EDT

Update

Our upstream provider is continuing to work on the issue, they report that a fix is being implemented. We We will continue to provide updates as we receive them.
Posted Aug 21, 2025 - 15:21 EDT

Identified

We have identified the issue as an upstream provider. We will continue to provide updates as we receive them.
Posted Aug 21, 2025 - 14:14 EDT

Investigating

The SmartTeach platform is currently experiencing degraded performance. We are investigating the root cause of the issue and will provide more information as soon as possible.
Posted Aug 21, 2025 - 13:32 EDT
This incident affected: SmartTeach (Library Area, Teach Area, Assess Area, Develop Area, Quorum, The Hub, Report Area, Family Area, Administration Area).