Platform Performance Issue - Assess

Incident Report for Teaching Strategies, LLC.

Resolved

The degraded performance issue in Assess has been resolved. Documentation search results for affected customers will reflect all updates from today in the next few hours - no action needed.
Posted Aug 12, 2025 - 22:32 EDT

Identified

Some users are currently experiencing issues with the “At a Glance”, “Checkpoints”, and "Documentation" sections of the Assess component of the Smart Teach platform. We have identified the root cause of the issue and are working on a resolution. We will provide updates as soon as possible.
Posted Aug 12, 2025 - 19:17 EDT
This incident affected: SmartTeach (Assess Area).