Platform Performance Issue - Quorum and The Hub
Incident Report for Teaching Strategies, LLC.
Resolved
This issue is fully resolved. You may need to clear your browser's cookies and cache if you are still experiencing issues.
Posted Aug 29, 2024 - 17:14 EDT
Monitoring
Quorum and The Hub are now operating as expected. We will continue to monitor the system to ensure the issue is fully resolved. You may need to clear your browser's cookies and cache if you are still experiencing issues.
Posted Aug 29, 2024 - 16:49 EDT
Investigating
Users are unable to access Quorum and The Hub from SmartTeach. We are currently investigating the root cause of the issue and will provide more information as soon as possible.
Posted Aug 29, 2024 - 16:12 EDT
This incident affected: SmartTeach (Quorum, The Hub).