All Systems Operational

About This Site

Welcome to the Teaching Strategies performance status page. This page provides up to date information about the availability of the Teaching Strategies online systems and solutions.

MyTeachingStrategies Operational
Library Area ? Operational
Teach Area ? Operational
Assess Area ? Operational
Develop Area ? Operational
Quorum Operational
The Hub Operational
Report Area ? Operational
Family Area ? Operational
Administration Area ? Operational
Tadpoles Operational
ReadyRosie Operational
FarFaria Operational
Technical Support ? Operational
Support Portal Operational
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Scheduled Maintenance
System Maintenance - April 24 Apr 24, 2024 21:00 - Apr 25, 2024 00:00 EDT
Due to system maintenance, MyTeachingStrategies and its solutions will be unavailable on April 24 from 9:00PM EDT to 12:00AM EDT. We appreciate your patience and understanding as we make important updates to the platform.
Posted on Apr 12, 2024 - 15:02 EDT
Past Incidents
Apr 18, 2024

No incidents reported today.

Apr 17, 2024

No incidents reported.

Apr 16, 2024

No incidents reported.

Apr 15, 2024

No incidents reported.

Apr 14, 2024

No incidents reported.

Apr 13, 2024

No incidents reported.

Apr 12, 2024

No incidents reported.

Apr 11, 2024

No incidents reported.

Apr 10, 2024

No incidents reported.

Apr 9, 2024
Completed - The scheduled maintenance has been completed.
Apr 9, 10:00 EDT
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Apr 9, 08:00 EDT
Scheduled - Due to system maintenance, Quorum will be unavailable on April 9 from 8:00AM EDT to 10:00AM EDT. We appreciate your patience and understanding as we make important updates.
Mar 29, 12:15 EDT
Apr 8, 2024

No incidents reported.

Apr 7, 2024

No incidents reported.

Apr 6, 2024

No incidents reported.

Apr 5, 2024
Resolved - This issue is fully resolved. You may need to clear your browser's cookies and cache if you are still experiencing issues.
Apr 5, 17:32 EDT
Update - We are continuing to monitor the resolution from our third-party provider. Tadpoles dashboard is now operating as expected. We will continue to monitor the system to ensure the issue is fully resolved. You may need to clear your browser's cookies and cache if you are still experiencing issues
Apr 5, 12:03 EDT
Monitoring - Our third-party provider has provided a fix for the functionality affecting the Tadpoles Admin Dashboard. We are now monitoring the resolution.
Apr 5, 03:05 EDT
Identified - Realtime connections for the Tadpoles admin dashboard are intermittently failing due to a third party provider issue. This results in the dashboard not loading fully until the connection can be made. There is no impact to the mobile applications
Apr 4, 17:12 EDT
Apr 4, 2024